Why is SAFe 4.0 being retired?

You are here:
< Back

SAI supports prior versions of the framework for one year following introduction of a new version. SAFe 4.5 was introduced in June 2017, so after more than a year of support, SAFe 4.0 is being retired.

Last Updated On August 08, 2018